Home - Forums-.NET - FlyTreeView (ASP.NET) - How do I remove scrollbars

FlyTreeView (ASP.NET)

Technical support and KB related to the FlyTreeView control

This forum related to following products: FlyTreeView for ASP.NET

How do I remove scrollbars
Link Posted: 01-Apr-2007 18:17
I have a left column navigation and I can't seem to remove the scrollbars from it.  How do I remove it?
Link Posted: 01-Apr-2007 21:39
FlyTreeView enables scrollbars when it has fixed values of Width and Height properties.
You can clear them so scrollbars will not appear.
Link Posted: 05-May-2008 14:19
I've set up my treeview without specifying the height and width.  The parent container of the treeview implements it's own scrolling so I don't want the treeview's scrollbars to show, but they still do.  Is there a CSS style that I can apply to the treeview or something of the sort that will turn them off?

Thanks,
Matt
Link Posted: 05-May-2008 22:23
Matt,
Scrollbars should not appear when Width/Height are blank.
Could you post here a sample (treeview settings + outer element that has its own scrollbars)?
Link Posted: 06-May-2008 12:46
Hi, below is code that will show the horizontal scrollbar even though a width and height attribute are not present on the TreeView: [code] <%@ Register Assembly="NineRays.WebControls.FlyTreeView" Namespace="NineRays.WebControls" TagPrefix="NineRays" %> Untitled Page
[/code] If I view the source, I can see on the tree's div that there is a style="overflow:auto" attribute which is causing the problem. How can I stop the Treeview from adding this attribute at runtime? Thanks, Matt
Link Posted: 06-May-2008 23:34
Matt,

This should help:
Link Posted: 03-Dec-2012 22:08
How do I remove the flytreeview scrollbars´╝č
I have a left column navigation and I can't seem to remove the scrollbars from it.  How do I remove it?
I've set up my treeview without specifying the height and width.  The parent container of the treeview implements it's own scrolling so I don't want the treeview's scrollbars to show, but they still do.  Is there a CSS style that I can apply to the treeview or something of the sort that will turn them off?  If I view the source, I can see on the tree's div that there is a style="overflow:auto" attribute which is causing the problem. How can I stop the Treeview from adding this attribute at runtime? and the issue has happend only by IE8 and IE+ browser. other browser, such as Firefox anf chrome and so on is ok.thanks!